1

Тема: Проброс портов для сервера АРМ10 за NAT

Здравствуйте!

Подскажите, какие порты необходимо пробросить для сервера находящегося за NAT и какие необходимо настройки сделать?

На локалхосте клиент АРМ10 работает прекрасно, но вот удаленно ни как заставить его работать не могу.
Настройки портов SysX дефолтные. Проброшены 5551, 5552, 5553, 5554, 5556. Файрвол отключен, nmap сообщает, что порты открыты, но клиент все равно пишет в статусбаре, что нет подключения.

2

Re: Проброс портов для сервера АРМ10 за NAT

iEvgeny пишет:

Здравствуйте!

Подскажите, какие порты необходимо пробросить для сервера находящегося за NAT и какие необходимо настройки сделать?

На локалхосте клиент АРМ10 работает прекрасно, но вот удаленно ни как заставить его работать не могу.
Настройки портов SysX дефолтные. Проброшены 5551, 5552, 5553, 5554, 5556. Файрвол отключен, nmap сообщает, что порты открыты, но клиент все равно пишет в статусбаре, что нет подключения.


Сила в настройке "рассылки" . иными словами, делаете нового диспетчера на вкладке клиенты. (по аналогии с тестовым диспетчером). Доступ 12, полный доступ  и.т.д.


На вкладке рассылка , для нового диспетчера создаются 3 рассылки (по аналогии с тест диспетчером). Только в URL указывается не http://localhost:.... а http://Внешнийайпи:...  или http://внутреннийайпи:...

One fleeting moment and it's all gone...

3 (04-11-2016 22:44:14 отредактировано iEvgeny)

Re: Проброс портов для сервера АРМ10 за NAT

Выполнил ваши инструкции:
Создал клиента полностью по аналогии с тестовым диспетчером. Для клиентов "Шлюз" и "Сервер отчетов" поставил галочки в таблице доступа аналогично с тестовым диспетчером. Настроил для нового клиента список отчетов и список ТС. Создал аналогичные рассылки, но с "внешним" IP и получил ошибку в логах на клиенте: "В доступе отказано"...

Однако при изменении для тестового диспетчера IP в рассылках на тот, что указывал для нового клиента и логином с учетными данными первого, все работает...

Пожалуйста, подскажите. Где я допустил ошибку при создании нового клиента и рассылок для него?

P.S.
И постоянно, после ее удаления, появляется странная строчка под номером 0 в списке рассылок.
P.P.S.
БД находится на внешнем сервере.

4

Re: Проброс портов для сервера АРМ10 за NAT

iEvgeny пишет:

Выполнил ваши инструкции:
Создал клиента полностью по аналогии с тестовым диспетчером. Для клиентов "Шлюз" и "Сервер отчетов" поставил галочки в таблице доступа аналогично с тестовым диспетчером. Настроил для нового клиента список отчетов и список ТС. Создал аналогичные рассылки, но с "внешним" IP и получил ошибку в логах на клиенте: "В доступе отказано"...

Однако при изменении для тестового диспетчера IP в рассылках на тот, что указывал для нового клиента и логином с учетными данными первого, все работает...

Пожалуйста, подскажите. Где я допустил ошибку при создании нового клиента и рассылок для него?

P.S.
И постоянно, после ее удаления, появляется странная строчка под номером 0 в списке рассылок.
P.P.S.
БД находится на внешнем сервере.


По идее, в диспетчерском софте (находящимся в вашей подсети 192.168.1.Х), необходимо прописать
логин: disp пароль: disp
идентификатор:1 тип:5
URL: http://192.168.1.1:5552

*Предварительно добавив диспетчеру "disp" транспортных средств.

One fleeting moment and it's all gone...

5

Re: Проброс портов для сервера АРМ10 за NAT

Большое спасибо за помощь!
В моем случае элементарная невнимательность была всему причиной.
Забыл поменять идентификатор клиента.

6

Re: Проброс портов для сервера АРМ10 за NAT

То есть порты пробрасывать именно эти?
5551-5554 и 5556   ?


5555 пробрасывать надо?

7

Re: Проброс портов для сервера АРМ10 за NAT

Strange пишет:

То есть порты пробрасывать именно эти?
5551-5554 и 5556   ?


5555 пробрасывать надо?

По умолчанию порт 5555 использовался в минисервере как 2й порт для соединения приборов работающих по протоколу v3, в шлюзе 10 сервера порт для v3 - 1100.

Ведущий инженер-испытатель технической службы
ЗАО "Сантэл-Навигация"
E-mail: support@santel-navi.ru
Сайт:   www.santel-navi.ru